Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 20, 2025 - 18:00 BST
Scheduled
Dear Members,
We will be carrying out essential maintenance to connect our new Solar PV system to the building’s incoming mains power.
Details:
Area/Equipment Affected: Entire building
Date: Wednesday 20th August 2025
Time: 18:00 – 21:00
Expected Impact: Full power outage across the building for up to 3 hours
During the Maintenance:
There will be no electricity throughout the building, including offices, communal areas, and meeting rooms.
IT equipment and servers will not be able to remain powered during this time.
If you have essential items that must remain powered, please let us know in advance so that arrangements can be made where possible.
Safety Precautions:
Emergency lighting will be available, but limited.
For your safety, we recommend avoiding entry to the building during the maintenance window unless absolutely necessary.
We apologise for any inconvenience caused and appreciate your cooperation as we complete this important upgrade to support our sustainability efforts.
Kind regards, The Engine House Team
Posted Aug 18, 2025 - 15:47 BST
This scheduled maintenance affected: Phoneline Service Ground Floor, Phoneline Service First Floor, Phoneline Service Second Floor, Ground Floor Internet Service, First Floor Internet Service, Second Floor Internet Service, Ground Floor Studios & Fixed Desk Co-Working, First Floor Studios, Second Floor Studios, and Elevators/Lifts.