Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 26, 2026 - 08:30 BST
Scheduled
Air Conditioning Servicing – Planned Maintenance
📅 Start: Tuesday 26th May 2026 – 08:30 📅 Expected Completion: Thursday 28th May 2026 – 17:00 📍 Location: All offices and communal areas
What’s happening: Routine 6-monthly servicing of the building air conditioning systems will be taking place across the Engine House.
Expected impact:
Air conditioning and ventilation within offices may be intermittently affected while servicing is carried out Engineers will require access to individual offices and communal areas throughout the maintenance period There may be temporary interruptions to heating/ventilation functions while units are being serviced
Member access: There are no access restrictions, and members may continue to use the building as normal during the works.
Please note: Please be mindful of engineers working in and around offices and communal spaces during this period.
Thank you for your cooperation while these routine maintenance works are completed.
Posted May 21, 2026 - 16:48 BST
This scheduled maintenance affected: Ground Floor Studios & Fixed Desk Co-Working, First Floor Studios, and Second Floor Studios.