Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 13, 2025 - 08:30 BST
Scheduled
Dear Members,
Please be advised that scheduled maintenance on the air conditioning units at The Engine House Bexley will take place on the following dates:
🛠 Dates: Monday 13th & Tuesday 14th May 🕐 Time: All day (both days) 📍 Area Affected: Offices throughout the building
As part of this essential servicing, engineers will require brief access to your office during the maintenance window. We kindly ask that you ensure access is available on these dates to allow the work to proceed smoothly.
What to Expect: Short-term access to your office for air conditioning unit servicing Engineers working on-site during the day While no alternative arrangements are necessary, we appreciate your cooperation and awareness of the work taking place.
Thank you for your understanding and support as we work to maintain a comfortable environment for everyone.
Warm regards, The Engine House Bexley Team
Posted May 12, 2025 - 09:25 BST
This scheduled maintenance affected: Ground Floor Studios & Fixed Desk Co-Working, First Floor Studios, and Second Floor Studios.