Service Update: Lift 1 Out of Order

Incident Report for The Engine House Status Page

Investigating

Dear Members,

We regret to inform you that Lift 1 is currently out of service. Our maintenance team is working diligently to resolve the issue and ensure the lift is operational as soon as possible.

Key Details:

Issue: Lift 1 is out of service
Repair Status: Lift engineer called

We apologise for any inconvenience this may cause and appreciate your understanding. Please use Lift 2 during this time. If you require any assistance or have accessibility needs, our team is here to help - do not hesitate to reach out.

Thank you for your patience as we work to restore full service.

Kind regards,
The Engine House Team
Posted Mar 03, 2026 - 16:36 GMT
This incident affects: Elevators/Lifts.