Lift 2 Out of Service

Incident Report for The Engine House Status Page

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 11:29 GMT

Identified

Lift 2 (Floors 1–2) is currently out of service due to a technical fault. We’re working with our contractor to resolve this as soon as possible.

🔹 Please use Lift 1 or the stairs.
🔹 If you require assistance or have a PEEP in place, speak to a member of our team.

Thanks for your patience.
Posted Feb 05, 2026 - 09:12 GMT
This incident affected: Elevators/Lifts.