Interruptions to Wi-Fi and Phone Systems
Incident Report for The Engine House Status Page
Resolved
This incident has been resolved.
Posted Feb 08, 2024 - 11:31 UTC
Monitoring
The team are aware and we are currently working to rectify the issue
Posted Feb 07, 2024 - 12:40 UTC
This incident affected: Phoneline Service First Floor, Phoneline Service Second Floor, Second Floor Internet Service, and First Floor Internet Access.