Internet & Broadband Issues

Incident Report for The Engine House Status Page

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 13:30 GMT

Update

This issues has now been revolved.
Posted Nov 03, 2025 - 13:28 GMT

Investigating

Dear Members,

We are currently aware that some studios are having issues with their internet/routers, we are aware of the issue are are working hard to resolve the issue.

We will update all members shortly.

All the best

EH Team
Posted Nov 03, 2025 - 10:59 GMT
This incident affected: Phoneline Service Ground Floor, Phoneline Service First Floor, Phoneline Service Second Floor, Ground Floor Internet Service, First Floor Internet Service, and Second Floor Internet Service.