Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Nov 18, 2024 - 11:19 GMT
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Nov 15, 2024 - 10:07 GMT
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Nov 15, 2024 - 10:02 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 15, 2024 - 08:30 GMT
Scheduled
Dear Members,
We wish to inform you that Lift 2 will be out of order until Monday afternoon due to necessary repairs. During this time, we kindly ask you to use Lift 1 for your convenience.
We apologize for any inconvenience this may cause and appreciate your understanding as we work to resolve this issue promptly.
Thank you for your patience and cooperation.
Kind regards,
The Engine House Team
Posted Nov 15, 2024 - 08:15 GMT
This scheduled maintenance affected: Elevators/Lifts.